(Hot CPU Tester Pro Help Index)

Welcome to Hot CPU Tester Pro 4 Documentation

Hot CPU Tester Pro is a system health and stability tester. It tests CPU, chipset and virtually all parts of motherboard for errors/bugs, defective parts and components. It is a burn-in test with uniquely designed state of the art DefectTech engine. DefectTech is a technology developed by 7Byte to diagnose systems regarding its stability and in general, computer's health. Hot CPU Tester is currently being used in many labs and governmental organizations around the world, as a reliable stability testing utility.

How it works:
Hot CPU Tester has several testing modules which test CPU, caches, chipset, memory modules and other parts of the motherboard. It is most likely for weak or defected parts to fail while they are under heavy load and when the heat production is high. The testing modules intentionally overload all components to the maximum limits to exhibit their integrity. Unstable parts cannot endure these pressures and soon they will fail the tests. Hot CPU Tester should run for several hours to check the system. 6 hours would be enough. If a system is stable under hard conditions for 6 hours it is unlikely to generate error during normal conditions.
Copyright©1999-2003 7Byte Computers, Inc. All rights reserved. Hot CPU Tester is a registered trademark of 7Byte Computers, Inc. All registered names and trademarks are the property of their respective owners.
http://www.7byte.com
info@7byte.com


Diagnostic
Diagnostic tab is the main window of Hot CPU Tester. Diagnostic modules can be ran or stopped from here. It also displays information on test modules status.
  1. Module: Displays module name.
  2. Progress: Displays progress of one cycle(iteration) of the module
  3. Run: Number of cycles(iterations) the module has successfully passed.
  4. Status: Console box for the module. All info & error messages regarding the module is shown here.
  5. Run Test/Stop Test: Start/Stop button for diagnostic test.
  6. Elapsed Time: Displays how much time is passed since the test started.
  7. Test Started At: Displays start time of the test.
  8. Will Finish At: Displays the time test will finish.
  9. CPU Performance Ratio: Displays performance ratio of the CPU percentage. CPU Performance ratio is calculated by the following algorithm:
    1. CPU speed in MHz while idle => base_speed
    2. CPU speed in MHz while test is running=> current_speed
    3. (current_speed/base_speed)*100 => cpu_performance(in %)
  10. Show Log: Displays/Hides the log window.
Copyright©1999-2003 7Byte Computers, Inc. All rights reserved. Hot CPU Tester is a registered trademark of 7Byte Computers, Inc. All registered names and trademarks are the property of their respective owners.


Burn-in

Burn-in is designed solely to burn in the system. While "Diagnostic Modules" are suited for finding errors they do not generate maximum heat because of several checksum routines.

CPU Burn-in test is the same as Complex Matrix module except it doesn't have any routines to verify the results. It burns in ALU(Arithmetic and Logic Unit) to its maximum extent.

Memory Burn-in test is designed to put maximum load on memory with lowest side effects on CPU. It uses the following algorith

  1. Allocate memory in RAM(as much as specified)
  2. Fill it with Random data
  3. Divide the allocated memory in half
  4. Move data from the first half to the second half
  5. Move back data from the second half to the first half
  6. Go to 2
  1. Number of Threads to Run(CPU): Specifies number of CPU burn-in threads to run. For Hyper-Threaded CPUs or SMP systems select the number of CPUs(or virtual CPUs) available in the system. Windows automatically ballances threads CPUs.
  2. Run CPU Burn-in/Stop CPU Burn-in: Starts/Stops CPU Burn-in.
  3. Run Memory Burn-in/Stop Memory Burn-in: Starts/Stops Memory Burn-in.
  4. Number of Threads to Run(Memory): Specifies number of Memory burn-in threads to run. For Hyper-Threaded CPUs or SMP systems select the number of CPUs(or virtual CPUs) available in the system. Windows automatically ballances threads CPUs.
  5. Memory Size: Specifies memory size to be allocated for Memory burn-in.


Benchmark

Benchmark is consisted of more than 48+ synthetic tests to benchmark system performance. It is derived mostly from MetaBench.
  1. Total Score: Overall score calculated by the benchmark. This score does not include MMX, SSE, SSE2, and 3DNow! test scores as they are CPU dependants.
  2. Save: Saves test result into a file.
  3. Print: Prints test result to a printer.
  4. Run: Runs Benchmark.

    5. Note: Benchmark cannot be stopped once it is started. To finish the benchmark you need to close the program through Task Manager.


System Info
System Info displays system information which is read from the SMBIOS and CPU. CPU Speed is measured through RDTSC clock.
  1. Cache: Displays Cache information
  2. Print: Prints System information
Copyright©1999-2003 7Byte Computers, Inc. All rights reserved. Hot CPU Tester is a registered trademark of 7Byte Computers, Inc. All registered names and trademarks are the property of their respective owners.


Options : Hot CPU Tester

Options -> Hot CPU Tester
  1. Export Setting To a .reg File: Saves Hot CPU Tester's settings to a registry file(.reg) which can be editted or imported to Windows by regedit.exe program.
  2. Import Settings from a .reg File: Loads Hot CPU Tester's settings from a registry file(.reg) into Hot CPU Tester.
    Note: Program must restart to complete this action.
  3. Log File Location: To change location of log file.
  4. Foreground Color: To change foreground color of text boxes.
  5. Background Color: To change background color of text boxes.
  6. Sample Text Box: A sample text box to preview foreground and background colors.


Options : Modules

Options : Test Modules
  1. Diganostic Duration: Number of hours to test the system. Enter '0' for infinity. Test can be stopped manually at any moment by pressing the stop button in diagnostic mode.
  2. Diagnostic Method: There are two diagnostic method available for testing system:
    1. Simultaneous: In Simultaneous mode, all modules are ran together simultaneously in separate threads. All previous versions of Hot CPU Tester use this method for testing.
    2. Sequential(Queued): In Sequential mode, modules are ran sequentially in separate threads. All threads are created in suspended mode in a queue. Then, Hot CPU Tester activates the first thread(module) in the queue. After it is finished, Hot CPU Tester activates the next thread in the queue, and repeat this process until it reaches the end of queue and start the process all over again. This is the preferred way to test the system.
  3. Error Handling: Error Handling tells Hot CPU Tester how to react when an error occurs. There are two modes:
    • Ignore and Continue: In this mode Hot CPU Tester continues testing even after an error occurs until it is stopped manually or reaches its timer.
    • Abort the test: Aborts the test if an error occurs while testing.
  • Enable Hyper-Threading: This options is available only on Hyper-Thread enabled CPUs. Normally, Hot CPU Tester would only run one set of modules for each physical CPU. When this option is enabled Hot CPU tester run one set of modules for each logical CPU. For instance: In a signle processor Hyper-Threaded CPU, if this option is disabled Hot CPU Tester would only run one set of test on the CPU(Windows automatically ballances thread loads on logical CPUs). When this option is enabled Hot CPU Tester runs two set of tests for each logical CPU.
  1. Processors: To select which CPUs to test. Hot CPU Tester would run a set of modules on each physical CPU selected if “Enable Hyper-Threading” is unchecked. Otherwise, It would run a set of modules on each logical CPU.


Options -> Modules : Complex Matrix

Options -> Module : Complex Matrix

  1. Modules: Complex Matrix: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.
  3. Number of Items in Matrix: Determinse size of the matrix used for testing/diagnosing.
    Note: Using a size larger than available memory to the process may result in Memory Exception Error.

    Matrix Data Type:
  4. Floating-Point(Double precision): Uses double precision floating-point data type for the matrix items which results in stressing the floting point portion of the CPU.
  5. 64-bit Integer(QWORD): Uses 64-bit integer(QWord) data type for the matrix items which results in stressing the inter portion of the CPU.


Options -> Modules : Calculating Pi

  1. Modules: Calculating Pi: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.
  3. Memory Needed: Determines size of the memory being used for Pi calculations.
  4. Total Number of Iterations: Number of Iterations/Loops for calculation. Larger number means more calculation and better precision. It uses Machin's formula, pi/4 = 4 arctan(1/5) - arctan(1/239), combined with the Gregory series for computing arctang


Options -> Modules : Sorting Algorithms

  1. Modules: Sorting Algorithms: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.
    Algorithms:
  3. Insertion Sort: Enables Insertion Sort algorithm test, written purely in C++, using a simple C++ array.
  4. Shell Sort: Enables Shell Sort algorithm test, written purely in C++, using a simple C++ array.
  5. Merge Sort: Enables Merge Sort algorithm test, written purely in C++, using a simple C++ array.
  6. Heap Sort: Enables Heap Sort algorithm test, written purely in C++, using a simple C++ array.
  7. Quick Sort: Enables Quick Sort algorithm test, written purely in C++, using a simple C++ array.
  8. Quick Sort(MFC CArray method): Enables Quick Sort algorithm test, using MFC CArray class and STL(Standard Typle Librart)Quick Sort. This is equivalent to QuickSort test in Hot CPU Tester Pro 3.
  9. Array Size: Determines Size of the Array being used for sorting algorithms.


Options -> Modules : Prime Test

  1. Modules: Prime Test: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.
  3. Total Number of Iterations: Determines the number of iterations used for finding prime numbers, i.e. a Total number of iterations of 100,000 means finding all prime numbers up to 100,000.


Options -> Modules : Fast Fourier Transforms

  1. Modules: Fast Fourier Transforms: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : Chipset

  1. Modules: Chipset: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : L1 Cache
  1. Modules: L1 Cache: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : L2 Cache
  1. Modules: L2 Cache: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : Memory
  1. Modules: Memory: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.
  3. Testing Memory Size in Megabytes: Determines siize of memory to be tested.
    Caution: Do not allocate more than 90% of available memory. If so, it would use Swap Files instead which would defeat the purpose of testing memory modules in the first place.


Options : Hard Disk

Options -> Modules : Hard Disk
  1. Modules: Hard Disk: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.
  3. Drive to Test: Determies the physical/logical drive to be tested/
  4. Test Size in Megabytes: Specifies the size of HD to be tested.
    Caution: Make sure you have enough free space on the specified drive.


Options -> Modules : MMX
  1. Modules: MMX: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : SSE
  1. Modules: SSE: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : SSE2
  1. Modules: SSE2: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options -> Modules : 3DNow!
  1. Modules: 3DNow!: Enables/Disables the module.
  2. Thread Priority: Determines the priority of the thread which the test module is being ran.


Options : LiveSupport

Options -> LiveSupport

  1. SMTP Server: SMTP server address for out going mails. It is provided by ISP.
  2. Port Number: SMTP port number. Default port number is 25.
  3. Authentication: SMTP server authentication method, there are three options available:
    • None: No login required.
    • Plain Login: Plain Login with password.
    • Authorized Login: Authorized login with password.
    • CRAM MD5: Authorized login with secure encrypted MD5 password/user authentication.
  4. User Name: User name for the SMTP server.
  5. Password: Password for the SMTP server.
  6. Auto Connect to the Internet: Connects to the internet if not connected.


Options : Debug

Options -> Debug

  1. Verbose Log: Enables/Disables verbose log for debugging purpose.
  2. Generate MiniDump When: Generates a MiniDump file (.dmp) whenever:
    1. A calculation error occurs: Generates a MiniDump whenever a calculational error occurs in one of test modules.
    2. An exception error occurs: Generates a MiniDump whenever the program generates an exception error.
  3. MiniDump Type:
    • MiniDump Normal: Include just the information necessary to capture stack traces for all existing threads in a process.
    • MiniDump With Data Segments: Include the data sections from all loaded modules. This results in the inclusion of global variables, which can make the minidump file significantly larger.
    • MiniDump With Full Memory: Include all accessible memory in the process. The raw memory data is included at the end, so that the initial structures can be mapped directly without the raw memory information. This option can result in a very large file.
    • MiniDump Filter Memory: Stack and backing store memory written to the minidump file should be filtered to remove all but the pointer values necessary to reconstruct a stack trace. Typically, this removes any private information.
    • MiniDump Scan Memory: Stack and backing store memory should be scanned for pointer references to modules in the module list.
    • MiniDump With Process & Thread Data: Include complete per-process and per-thread information from the operating system.
    • MiniDump With Private Read & WriteMemory: Scan the virtual address space for other types of memory to be included.


LiveSupport
LiveSupport enables users to contact Hot CPU Tester's Support Team to get assistance. It send the program log file and all MiniDump generated debug files for inspecting and analyzing the problem. User will be contacted from the Support Team for assistance in a timely manner.
Note: All data sent to 7Byte is solely for better assisting the user and fully confidential and they will be deleted from 7Byte's server after the problem is solved and/or by user's request.
  1. Check for Update: Check for a new version on 7Byte Computer's server.
  2. e-mail Address: User's e-mail address to be contacted from 7Byte Computers.
  3. Full Name: User's Full name.
  4. Detailed description of problem and/or other additional info: Include a detailed description of problem occuring on the system.
  5. What is being sent?: Displays a list of files to be sent to 7Byte Computers. Files can be opened by double clicking on them.
  6. Submit: Submits data to 7Byte Computers for further inspection.